Bem-vindo ao nosso Suporte

Faça sua pesquisa digitando palavras-chave abaixo ou veja a nossa base de conhecimento.

I54-Erro 3014 no acesso ao GAP na Estação

Seguir

Sumário

Sistema: Gerenciador de Aplicativos Prosoft (GAP)

Contexto: Este artigo tem como objetivo orientar o usuário em como proceder quando ao tentar acessar o Prosoft na estação, ocorre: “Falha ao tentar verificar versões do arquivo. 3014 - Falha ao abrir o arquivo "?:\Prosoft.win\Gapversão.btr" Erro não documentado. (Rotina: CriarAbrirGapVersão)”.

Informações Adicionais:

A mensagem também pode ocorrer da seguinte forma:

“Falha imprevista na rotina VerificarVersoes

Número: 3014

Descrição: Falha ao abrir o arquivo ‘C:\Prosoft.win\GAPVERSAO.BTR’:

Erro: não documentado. (Rotina: CriarAbrirGapVersao)” 

Resolução

A situação ocorre devido à falha na comunicação do Pervasive Client da estação com o Pervasive Workgroup/Server do servidor, muitas vezes por falha de ambiente.

Importante: Na maioria dos casos quando ocorre o erro 3014 apenas na estação, o motivo é falha de ambiente.
Caso os procedimentos deste conhecimento não resolvam será necessária uma análise de ambiente pelo TI da empresa ou Canal Regional.

1- Acesse: Menu Iniciar > Executar.

2- Digite PCC.

3- Acesse Configure MicroKernel Router.

4- Desmarque a opção Use Local Microkernel Engine e deixe selecionada apenas a opção Use Remote Microkernel Engine.

5- Solicite ao TI da empresa que faça a liberação das portas 3351 e 1583 (ambas TCP) no ambiente.

6- Acesse: Menu Iniciar > Executar.

7- Digite services.msc.

8- Localize o Serviço Pervasive PSQL Client Engine e clique em Reiniciar.

Importante: Caso não exista o serviço do Pervasive, será necessário reinstalar o mesmo na máquina como serviço.

9- Realize os seguintes procedimentos:


Reinstalação do Pervasive Client:

Obs.: Para maiores informações acesse o artigo 1119 - DESINSTALAÇÃO PERVASIVE - SERVIDOR E ESTAÇÃO.


Instalação do Pervasive 11.30 Client:

Obs.: Para maiores informações acesse o artigo 2922 - INSTALAÇÃO DO PERVASIVE 11.30 CLIENT.


Atualização do Pervasive 11.30 Client para 11.31:

Obs.: Para maiores informações acesse o artigo 11188 - ATUALIZAÇÃO DO PERVASIVE 11.30 CLIENT.
 

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 3

Comentários